2012年11月7日

解決 Eclipse 無法啟動問題:Failed to load the JNI shared libray


 
64位元的作業系統已經很普及了,因為他能兼容 64及 32位元的程式,
所以大家平常也不太 care 到底用的程式是哪一種。

先前因為 Java 出現在一些安全性的問題,
加上電腦裡安裝了 Java 6, 7 的 32 bit, 64bit 再分為 JRE 及 JDK 讓人覺得心煩,
就想說要把用不到的刪一刪,結果刪完後 Eclipse 就開不起來了 QQ
出現了這樣子的錯誤訊息:「Failed to load the JNI shared libray」。


原因是因為 Eclipse 雖然是免安裝,卻有分為 32及 64的版本,
如果 Eclipse 與 Java JVM 的版本對不上,就會出現這樣的錯誤訊息。
解決方法很簡單:確定 Eclipse 版本後裝上對應的 32或 64位元的 Java 即可。

關鍵字:Failed to load the JNI shared libray, Eclipse, Java, JVM, JDK, JRE
參考資料:


更多精選推薦文章