305 - Joseph
My Solved Problems Performance
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, ..., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0
Sample Output
5
30
Solution
關鍵字:UVa Online Judge, ACM. Java
- import java.io.BufferedInputStream;
- import java.util.Scanner;
- public class Main {
- static Scanner in = new Scanner(new BufferedInputStream(System.in));
- static int k, m, p, now, kill;
- public static void main (String[] args) {
- while ((k=in.nextInt())!=0) {
- Joseph(k);
- }
- }
- private static void Joseph(int k) {
- p = 2*k;
- now = 1;
- m = 2;
- while (p > k) {
- kill = (now+m-1)%p;
- if ((kill<=k)&&(kill!=0)) {
- p = 2*k;
- m++;
- now = 1;
- } else {
- now = (kill==0) ? 1 : kill;
- p--;
- }
- }
- System.out.println(m);
- }
- }
留言
張貼留言